Exchange Connector How to Address the “ACCESS to ODATA is disabled” Error.

Modified on Tue, 3 Mar at 1:08 AM

 

Objective: When the Reserve Exchange Connector is in place, at times the following message appears when sync is not working in both directions.

Error message: Operation: Create; Exception: [Status Code: Forbidden; Reason: Access to OData is disabled.]
Field   Value
@ingestionTime   1709652843896
@log   207066288020:Connectors
@logStream   ec-sample
@message   Error message: Operation: Create; Exception: [Status Code: Forbidden; Reason: Access to OData is disabled.]
@timestamp   1709652841532

 

Section 1

The reason for this error is because either EWS access is disabled for all client applications or if EWS access is allowed only for particular applications. To resolve this, you can check your current tenant EWS access policy by using the Exchange Online PowerShell cmdlet Get-OrganizationConfig. First, connect EXO PowerShell module and run the below command:

1 Get-OrganizationConfig | select EwsApplicationAccessPolicy, EwsAllowList, EwsBlockList
   

If you find any entries either for Allow access policy or Block access policy, then this might be the root cause for this error. If allow policy configured, then ensure that your client application is included for EWS access, or if block policy configured, then ensure that your client app is not included in the block list.

Run the below command to remove the applied EWS access policy.

1 Set-OrganizationConfig -EwsApplicationAccessPolicy $null

 

Section 2

In order to run the above you will need to contact your Exchange administrator or team to perform these actions.

  1. First, they will need to install the Exchange Online PowerShell Module with Install-Module ExchangeOnlineManagement. (if they haven’t already)
  2. Once the module is installed, connect to Exchange Online using the Connect-ExchangeOnline cmdlet. This cmdlet will prompt for your Microsoft 365 Exchange admin credentials.
  3. Once credentials are entered, you will be connected to the Exchange Online environment. From there, you should be able to use the commands in Section 1.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article